Will not work for me

Feb 19, 2012 at 7:01 AM

I've been working to try to get this to work for hours trying to put the correct values in the right properties but am having no success whatsoever. I'm trying to hook into a list with Lattitude and Longitude with Number data types. Strange thing is when I set the values for Centre Langitude and Centre Longitude, it maps but without a pin. I'm at a lost, with not a clue as to what I am doing wrong.

Coordinator
Feb 19, 2012 at 11:12 AM

Hi Webweaver,

It seems to me that there can be 2 possible problems:

  1. Format of Langitude or Longitude data. You wrote that you use number type so the only available format is  -40.446195
  2. Use internal names of columns

Try to check this.

Feb 19, 2012 at 8:48 PM

Hi Mazin,

Thanks for the quick response. I have decided to just use the address to get the points which seems to work occasionally. I'm using the Item Display form and the list I am using has multiple entries and it seems to be plotting all items in the list. I need for it to filter the list item to get one item. I'm using the 'List & Item ID' Data Mode and it seems that it's not taking the URL Parameter ID which I am simply setting to 'ID'. However when I created a list with only one item and apply the same settings it works sometimes.

The field I am using is the 'Address' field but the problem seems to be filtering down to the selected record. Is there a more reliable way to acheive this with another data mode? Perhaps a CAML approach would work but I don't know the CAML Query that would return a row based on the URL Parameter. Any help would be greatly appreciated.

Coordinator
Feb 20, 2012 at 10:00 PM

Hi Webweaver,

thank you for your post. I found error in List & Item ID mode. I think I have fixed it. Please download new release and try it again. Let me know in case of any troubles.

Feb 21, 2012 at 8:52 PM

Hi Mazin,

Thanks for your help. It appears to be working now however the pin does not seem to position on the direct location. Is there a setting for this? Otherwise the control works great! This is a great tool!

 

Thanks

Coordinator
Feb 22, 2012 at 1:07 PM

There are Centre langitude and Centre longitude properties. If they are set to zeros webpart tries to compute them dynamically using points to be displayed.